HLTV error...
Hey, can anyone help me?

well, after the steam atualization, my HLTV stoped working...

every time i launch it, appear this:
http://img510.imageshack.us/my.php?image=hltverror..

i dont know what to do, my hltv doesnt join servers. when i try to join servers (vac secured), my hltv closes...

thx.. =/
(41 replies)
Created 2008-10-29 15:59 by: xikOw
go to cstrike on counter-strike folder and take the steam_appid.txt and put it on dedicade server files and run hltv.exe

it works.

about linux no solution yet
2008-10-29 17:14:51
by: Nix0n - HLTV.org
#3
Linux is working just fine.
2008-10-29 17:15:25
by: Jonathan E. - HLTV.org
#4
Does this work on any Windows version?
2008-10-29 17:27:54
It does sir.

2011-08-06 02:37:13
by: Feck
#22
Thks! It's now working. Win XP.
2008-11-09 17:28:19
NICEE!!! =D
now working perfect... thanks !
nice 2k9
2009-01-01 10:57:46
thx!
2010-05-06 11:45:48
Thanks
2010-10-31 03:20:03
yes #4

#3 your hltv working on linux??? more info plz?

thnks
2008-10-29 19:26:42
by: Nomad - HLTV.org
#6
Sure, all HLTV.org servers have been running on Linux since the release.. :)
2008-10-29 19:30:12
by: Jonathan E. - HLTV.org
#13
You should seriously think about posting a blog entry where you explain the fix for linux as this appears to be quite an issue for linux hltv users :P xD
2008-10-29 20:26:58
how i can updat emine? i make update on hlds but nothing.. what i must to do? to fix the error?
------------
Console initialized.
FileSystem initialized.
Network initialized.
[S_API FAIL] SteamAPI_Init() failed; unable to update local steamclient. Continuing with current version anyway.
[S_API FAIL] SteamAPI_Init() failed; unable to locate a running instance of Steam, or a local steamclient.dll.
Master module failed to initialize. (init failed)
ERROR! System::AddModule: couldn't initialize module master.
***** FATAL ERROR *****
----------


thanks
2008-10-29 19:39:59
cool.....u got the start button's name changed to sumtng else :O
is it windows xp sp1 ?
2008-10-29 19:42:48
by: Jonathan E. - HLTV.org
#10
Looks like Portuguese (Brazilian) version of Xp (SP3 if the user is up to date with regard to the released SP ;)).

2008-10-29 19:54:35
Yeah it's portuguese. I think it's the same in Portugal or in Brazil
2008-10-31 16:09:33
Nomad you know about that error?
2008-10-29 19:54:31
by: MadeInLondon - HLTV.org
#11
he doesn't know anything about hltv on windows ;)
2008-10-29 19:59:35
i spoke about linux.. not windows side. i have debian on my dedi and i still searching solution how i can run the hltv on protocol 48.. i still have errors
2008-10-29 20:07:50
Well ill try the first solution,

I use Windows XP, not linux :P

brb to say if that worked

and thanks all ! :D
2008-10-29 22:59:28
Ohhhh thanks Nomad!!! :D

it worked pretty well

thanks all too! :]
2008-10-29 23:14:15
need solution for linux :/
2008-10-30 01:04:32
by: Nomad - HLTV.org
#17
What is your problem on linux?
2008-10-30 01:07:36
do yoh have any problems after update hltv ?
in windows ok, but linux hltv wont work ;]
2008-12-02 15:56:35
i post before the error message when i run it:

------------
Console initialized.
FileSystem initialized.
Network initialized.
[S_API FAIL] SteamAPI_Init() failed; unable to update local steamclient. Continuing with current version anyway.
[S_API FAIL] SteamAPI_Init() failed; unable to locate a running instance of Steam, or a local steamclient.dll.
Master module failed to initialize. (init failed)
ERROR! System::AddModule: couldn't initialize module master.
***** FATAL ERROR *****
----------

:/
2008-10-30 12:55:54
I'm also getting a similar error.

hlds@games1]$ ./hltv +connect 192.168.0.2:27035 -port 27099

Console initialized.
FileSystem initialized.
Error:libsteam_api_c_linux.so: cannot open shared object file: No such file or d irectory
WARNING! System::DispatchCommand: command "connect 192.168.0.2:27035" not registered.
Type 'help' for a list of commands.
connect 192.168.0.2:27035
WARNING! System::DispatchCommand: command "connect 192.168.0.2:27035" not registered.
2008-10-31 03:00:23
no-one can help? =/
2008-11-09 16:46:39
by: juks
#23
thanks a lot jesakos !!
it works fine now
2008-11-09 23:46:38
thanks Jesakos! :)
2008-11-10 01:03:48
#2 thanks for the tip, it works for me now! thank you verry much! =)
2008-12-13 13:10:21
For linux, before running HLTV
Run this command:
export LD_LIBRARY_PATH=/home/hlds?:$LD_LIBRARY_PATH
2008-12-13 13:57:45
Replace path with your actuall path :)
2008-12-16 11:58:28
thx this thread is very usefull dint knew to this for year but now thx to u guys i can start hltv :D
2009-04-05 16:12:29
Proxy.dll culls search the file and low and another was already = p
2010-06-22 02:33:06
I get a 0/0 Player Slot on mine help? And also no challenge for your address?
2010-07-27 03:13:20
by: Schypher - HLTV.org
#36
Don't add the HLTV to the favorites, you have to connect through the console - connect "ip here"
2010-10-31 03:33:32
The Windows XP is s*it:) as win7.:) but i useing windows
2011-01-19 15:42:02
by: Schypher - HLTV.org
#38
Stop bumping old threads, first check the date and then reply :p
2011-01-19 15:45:19
Created 2008-10-29 12:59
2011-01-19 15:45:39
I'm still having this exact problem, and I've created a steam_appid.txt with contents "10" (app_id for CS), and HLTV.exe still fails with the same exact error messages as this original post, what gives? (P.S. how does this error persist 2 years later? WTF?)
2011-08-06 02:22:00
by: Jonathan E. - HLTV.org
#41

Login or register to add your comment to the discussion.