FPS FIX
You need to enable again the multicore rendering option from your video.txt.

First go to your csgo cfg directory : steamapps/counterstrike:go/csgo/cfg and search for video.txt and open it.

Then search for "setting.mat_queue_mode" and set it on "2", then save your changes and make the document read-only.

This was the fix for me.
(160 replies)
Created 2014-02-06 12:03 by: gmd
will try when i get home, thx
2014-02-06 12:06:16
before 300 fps now 300 fps somting wrong here ;(
2014-08-29 19:26:37
omg work hahaha love u bro
2014-02-06 12:08:00
WORKS o.o, fps even higher than it was before? brutal dm fps 250 in b tunnels,before was like 200.
THANK YOU!
2014-02-06 12:10:46
WORKS!!! thnx
2014-02-06 12:11:05
Not for me...
2014-02-06 12:11:30
by: gmd
#6
Try -threads 4 in your launch options if you have quad-core cpu.(or 2 for dual-core)

Post edited 2014-02-06 12:12:46
2014-02-06 12:12:08
or 6 for 6-core :P
2014-02-06 12:13:49
or 4 for 2 cores with hyperthreading
2014-04-21 16:03:02
so i should do -threads 6? because i got a hexacore (phenom x6)
2014-02-06 12:14:48
by: gmd
#9
you should try.
2014-02-06 12:15:40
nevermind, works :D:D changed the video.txt and added -threads 6 to my launch options

from 80-100fps after the update yesterday to 250-300fps :D:D

thanks guys
2014-02-06 12:27:47
#cores and #threads don't always are same (example i7-4770K with 4-cores & 8-threads). Actually they are pretty different due to threads means the number of tasks each core can manage simultaneously. Therefore it depends on your processor model. You could see the real number with CPU-Z or similar software anyways dude :)

Post edited 2014-02-21 18:32:02
2014-02-21 18:29:59
yes
2014-02-06 12:15:55
This is working even before the update. But I did not try to play yet after the update. I have dual core so "-threads 2" ;)
2014-02-06 12:23:42
i've dualcore but if i use threads 2 my cs go crash...
2014-02-06 15:36:17
+1
2014-02-06 19:58:55
So if i have an i5cpu, what should my threads be on? -threads 4 right?

Post edited 2014-08-29 03:57:09
2014-08-29 03:56:27
works for me!
2014-08-29 05:16:12
It works :) thanks a lot mate
2014-02-06 12:18:50
Threads 4 improve my fps again, thx alot and God bless u
2014-02-06 12:21:47
did nothing for me.

i have a 3770k at 4.5ghz and i'm getting 50-150fps in 5v5...
2014-02-06 12:25:03
try -threads 8 i launch option
2014-04-21 15:25:01
-threads 4 is working my fps back to normal.
2014-02-06 12:26:04
Worked for me, but only after : "-threads 8" in launch option !

Thanks dude !
2014-02-06 12:27:23
made my fps even worse.
had 200
with this "fix" 160
p.s ok with -threads 4 working fine.

Post edited 2014-02-06 12:31:14
2014-02-06 12:27:38
Most of the CPU's have an own booster, so when you use only 2 cores it boosts up. Why sould I use 6cores at 2.4GHz instead of 2cores at 3.3GHz? (anyway, CS:GO don't really wanna allow the boost, so it is only working with game booster (razer gamebooster for example). but this is my sh*t. It is possible it works for you without GB).
I edited some sh*t here. It is not enough if you enable multicore rendering in your game! I enabled and that shit was on "-1" in the video.txt. I give it a try, i don't know the results yet.
Hate me. :D

Nice post!

Post edited 2014-02-06 12:31:12
2014-02-06 12:28:43
Worked for me, but only after : "-threads 8" in launch option !

Thanks dude ! !!!!!!!!!!!!!!!!!!!!!!
2014-02-06 12:30:43
+1
2014-02-06 12:32:09
WORKED FOR ME !!!! FPS BACK
2014-02-06 12:32:17
by: PusE
#23
gj dumi
2014-02-06 12:34:17
by: PD1
#73
Felicitati-va intre voi.
2014-02-06 15:15:58
by: PusE
#74
GJ dumi
2014-02-06 15:24:24
by: gmd
#75
=)
2014-02-06 15:25:14
GJ DUMI !!!
2014-02-06 15:26:18
I'm going to test this with different cores now. GET READY! :D
2014-02-06 12:34:43
hmm i dont even have file called video.txt ? :o
2014-02-06 12:35:21
makes me alittle better when u put threads in ur launch but not much./
2014-02-06 12:35:23
It works, thanks!
2014-02-06 12:36:29
increased the fps from 80 to 110 but still not good :( thanks anyway
2014-02-06 12:38:45
+ this update , my fps increased by 30-50
2014-02-06 12:40:23
It is still better with only 2 cores but with a booster than without a booster and using 6cores. That wasn't a question for me. :D
No fps improvement.
2014-02-06 12:40:49
by: zevo
#31
Intel Core 2 Quad Q8200

Set 2 or 4?
2014-02-06 12:45:30
You have Intel Booster in your CPU? If you are, then use it with 2cores. ( BUT be SURE that your CPU is using the booster! check the setting in BIOS, make sure you enabled it there, then give a try to the Razer GameBooster. It works fine for me!)
2014-02-06 12:49:31
Intel Core 2 Quad Q8200.
Core 2 Quad.
Quad.
2014-02-06 12:56:29
OMFG THANKS!!!

had an average of 110 after the update, changed this and put -threads 4 in startoptions and got 300 steady on offline dust2 without bots :D
2014-02-06 12:47:22
by: zevo
#33
Intel Core 2 Quad Q8200

Set 2 or 4?¿?¿?¿?

Help please!
2014-02-06 12:48:20
4

Quadcore = 4
Dualcore = 2

Post edited 2014-02-06 12:50:46
2014-02-06 12:50:00
4
2014-02-06 12:51:22
u dont know what's mean quad lololoololololololololololooolo
2014-02-06 13:09:33
you dont know how to speak proper english? Stop making fun of someone else then!
2014-02-06 13:41:14
mr. proper
2014-02-06 18:39:18
great reply you fat fuck. lmao
2014-02-06 18:52:30
i7 3630QM, how many cores I have? 4 I suppose?
2014-02-06 12:48:59
4
2014-02-06 12:50:07
http://ark.intel.com/products/71459

Number of cores: 4 :)
2014-02-06 12:51:36
ah but threads 8 so I should put -threads 8, ye?
2014-02-06 12:52:29
I think so, yeah. You can count your threads by going to Task Manager - Performance. Under CPU Usage History you see the number of threads you have (just count the boxes).

Post edited 2014-02-06 13:19:29
2014-02-06 13:17:59
thx mate it works after putting "-threads 4" in set lunch options
2014-02-06 12:49:12
by: zevo
#39
Intel Core 2 Quad Q8200

How many cores i have? 2 or 4?
2014-02-06 12:50:24
4 cores and 4 threads so -threads 4 in launch options
2014-02-06 13:26:44
by: Joz0
#83
intel core 2 duo cpu e 8400 @
2014-02-06 16:05:03
lol can't see anything after this
2014-02-06 12:52:31
thanks do me
2014-02-06 12:58:46
Hey my game keep crushing when i put threads 2, but when i put 4 its working fine and fps are normal (50-60). I have dual core, so where is a problem?
2014-02-06 12:59:47
by: gmd
#47
Game crashes randomly for everyone since the last update.
2014-02-06 13:01:11
Game crashes when i put "-threads 4" in launch options. Tried 2 and 8 aswell but it crashes the minute i connect to a server. I have a i5-4670k so im pretty sure I should be able to use -threads 4..If I dont have that command at all in launch options it works fine..But with much lower fps than before

Post edited 2014-02-06 13:07:58
2014-02-06 13:07:25
by: edgg
#52
disable multicore rendering
2014-02-06 13:14:55
What threads with i5 2500k ?
2014-02-06 13:09:56
Holy shit, i5 and i7 cpu has 4 cores.
2014-02-06 13:13:56
4
2014-02-06 13:17:54
I already have this and launch option -theards 4 etc .. fps increased a little :) cheers
2014-02-06 13:17:25
nice mine increased :)
2014-02-06 13:20:03
http://www.reddit.com/r/GlobalOffensive/comments/1..

Made a reddit post regarding the threads, couldn't see one on there.

Post edited 2014-02-06 13:21:42
2014-02-06 13:21:27
for i7 4770k?
2014-02-06 13:32:38
mat_queue_mode 2, but if launch options -threads 8

Post edited 2014-02-06 14:01:14
2014-02-06 13:57:49
yep working well
2014-02-06 13:38:48
changed mat_queue_mode from -1 to 2 and typed -threads 8 in my launch options

working well
2014-02-06 13:43:20
Thx alot mate! :)
2014-02-06 13:54:55
ILOVEYOU
2014-02-06 14:03:32
DUDE, I FUCKING LOW U, I FUCKING LOW U !!!!!!!!!
2014-02-06 14:06:55
amd fx6300 how many cores?
2014-02-06 14:09:20
msconfig,and see
2014-02-06 16:16:10
6
2014-02-06 18:47:23
Some dude in matchmaking told me the same thing and it works.

thanks bro
2014-02-06 14:09:59
by: t800
#69

Dual Core will have to enter -threads 2, Quad Core will have to enter -threads 4

Some Quad Cores can also use -threads 8, easy way to see how many threads you're using is to Ctrl + Alt + Delete, go to Performance, and see how many boxes there are under the "CPU Usage History"


Also some Dual-Cores can have 4 threads, so everybody should do this instead of above guide:


1. Right-Click Taskbar
2. Start Task-Manager
3. Performance Tab
Amount of Threads = Amount of Boxes in CPU Usage History


2014-02-06 14:17:58
I have a core 2 duo, in lauch options it´s -threads 2 but in video.txt file i have a doubt:

"setting.mat_queue_mode" - ?

"setting.mem_level" - 0 ?
2014-02-06 14:53:29
me 2. Need help. iF i set setting.mat_queue_mode to 2 and -threads 2 then cs:go crashes
2014-02-06 15:25:55
You can enter mat_queue_mode 2 in console. Same thing.
2014-02-06 19:26:58
WORKS NICEEEEEEEEE
2014-02-06 15:06:43
works THANKS

went from 30 fps to 35fps !!
2014-02-06 15:10:26
hahahahahahaha made my day :D

Post edited 2014-02-06 18:55:55
2014-02-06 18:55:46
hahahah :D:D
2014-02-06 20:02:09
by: ruyy
#78
When i set mat_queue_mode 2, my game start crashing after 4-5min
2014-02-06 15:30:24
worked! thanks from 90-100 to 250+
2014-02-06 15:32:00
worked :)
2014-02-06 15:52:02
Posting to remember, got to love this stuff, people here come up with the greatest stuff, thanks :)
2014-02-06 16:00:10
mat_queue_mode is the only command to boost fps.

i know, my english is bad !
2014-02-06 16:06:41
I think my FPS did not drop after the update. But Im not using "-threads 2" and I already tried threads 2 before the update but just decided not to use it just before the update.

Now, after the update, I tried to use -threads 2 but my CSGO is crashing even though I already change the mat_queue_mode into "2" from "-1".

BUT, I have mat_queue_mode 2 now and I DID NOT put threads 2 into launch option and it gives me maybe 20-30 more fps.
2014-02-06 16:22:29
try 4 wont crash
2014-02-06 20:03:48
now i play with 200+fps in a deathmatch with 20 people,before i played with like 130 :)
that mat queue mode did nothing but -threads 8 did

Post edited 2014-02-06 16:33:33
2014-02-06 16:25:11
same here mate and i have an i5 3570k procesor which doesnt support HT and have only 4 threads...very strange...with -threads 4 i had 100-110 fps on dm and with -threads 8 i have 200+ even goes 250+..
2014-02-06 18:42:33
im so happy :)
2014-02-06 18:51:14
i hawe core i3 (2 core)i use -threads 2 and cs crashed. Then i use -threads 4 and all work! bug fixed!
2014-02-06 19:10:28
i5 -threads 4 right?
2014-02-06 20:17:51
pentium dual core -threads 2 right ?
2014-02-06 20:27:07
projecMT ti pomogna ova brat?
2014-02-06 20:37:22
with -threads 2 crashing..:/
2014-02-06 20:40:38
guys if you want to fix bugs you can downloads this GUI all kind of bugs are already fixed enjoy it
http://csgo.gamebanana.com/guis/29703
2014-02-06 20:53:03
tnx!
2014-02-06 21:35:36
So should i out 2 in?
I got intel inside 5

I tried to put it like this.

"setting.mat_queue_mode" "2"
But please help me.. What more should i do? I dont get how or what i should do after i did set it to "2" instet of "-1"

Last thing... Should it be "-threads 2" OR just "2"
Please help!!
2014-02-08 12:49:36
you have and i5,in launch options set it as -4 threads
setting.mat_queue_mode" "2" <------ HERE JUST LEAVE IT "2"
2014-08-29 15:46:35
I guess it works, not that much of a difference at my end :/
2014-02-16 23:30:42
se vede ca romanii is heckari si buni la pc GJ
2014-02-17 00:07:44
I Guess it Workkkkkkkkkk forr ME tNx bro :)
2014-02-21 19:09:57
How do I make it read only?
2014-04-21 15:22:34
by: PPH
#112
intel(r) core(tm)2 quad cpu q6600 2.40 ghz how many threads ?
2014-04-21 15:50:49
-threads 4 with dat proc i have 80-120 fps )

Post edited 2014-04-21 16:00:02
2014-04-21 15:59:34
by: PPH
#117
yeah the fps is about the same as you wrote, thx btw :)
2014-04-21 19:53:24
Nice "fix". It should be on anyway by default.
2014-04-21 16:04:24
I'm still in doubt if I should use 4 or 8
http://ark.intel.com/products/64899/Intel-Core-i7-..
This is my processor. It has 4 cores but 8 threads. Which number should I use?
2014-08-19 10:57:39
8
2014-08-19 11:15:47
Thank you, I'll give it a try this evening and give feedback if it worked or not really
2014-08-19 15:23:37
Tried to put 8, 7, 6 and nothing... Bios updated, graphics updated

I have that I7, unparked and parked the cores (nothing as well)
16GB Ram
nvidia gt 650m
changed setting.mat's and stuff, nothing.

graphics low as possible.
multi core or not, same thing.

Resolution:
1920:1080 115/120 fps
1280:720 115/120 fps

doesn't move from there. And when I walk through a smoke I drop to about 40/30 fps and sometimes 20!
2014-08-20 01:17:20
by: woR
#119
OMG! From 300fps to 600fps THANK YOU SO MUCH!!!!!!!!!!
2014-08-19 11:06:10
mat_queue_mod 2 enable input lag40-50ms!!!
2014-08-19 11:09:52
ty

Post edited 2014-08-19 15:29:03
2014-08-19 15:27:54
holyshit worked for me tnx bro
2014-08-20 01:43:41
Hmm - did not seem to work for me. Which values should I be using? I have an i7 920, so I assume I should be writing 4 in the .txt file and -threads 8? And what about multicore rendering?

I think before I was playing simply with -threads 8 and this is how I seem to get the best results. But I noticed that my FPS is a little low anyway, probably at the upper end of the 100s? I was expecting to get more out of my GTX 580? What settings should I primarily be lowering? AA and AF?

Are there any up to date guides on optimising your FPS?
2014-08-20 02:19:24
You should be writing "2" in mat_que_mode with any kind of setup... threads depends on procesor.
2014-08-29 03:15:01
Even with quad core?
2014-08-29 16:50:40
yes.. basicly 2 means force all cores..
2014-08-29 18:45:27
I see - thanks!

So 2 in the .ini and -threads 8 in launch parameters?
2014-08-29 19:07:17
Well if your procesor has 4 cores and 4 virtual then -threads 8 yes.. you should be able to check that easily on google.
2014-08-29 19:09:15
Yeah, it is a quad core and I am pretty sure it has 8 threads (8 of those graphs show up in the resource manager, at least). What about the ingame setting "multicore rendering"? On or off?
2014-08-29 19:11:56
It should be ENABLED ofc..
2014-08-29 19:35:56
ty
2014-08-29 00:38:00
stable 200fps ;) awesome, i will test this on z510 today, thanks mate.!
2014-08-29 02:24:08
I find that queue mode 2 increase the game's latency by ~10ms.

Post edited 2014-08-29 02:37:08
2014-08-29 02:33:48
i7 960.. thread 8 or 4?
2014-08-29 02:47:52
how do i make it read only
2014-08-29 03:30:29
thanks mate :- D 50+ fps for me :)
2014-08-29 03:49:42
Intel Core i5-2500

???
2014-08-29 03:53:48
i7-2600k how many threads?
2014-08-29 03:56:48
Intel Core 2 Quad Q8200

SOMEbody pls 2 or 4
2014-08-29 04:16:48
Did nothing for me :/
2014-08-29 04:35:34
Prescribed and nothing happened.
2014-08-29 15:40:17
120-300 O.O

Thanks!
2014-08-29 15:43:26
de 5 luni este asta =))
vai de capu tau .^_^
2014-08-29 15:48:52
didn't work for me, i have an i5 3330 and wrote -threads 4 in launch options and mat_que_mode "2" and im still with 60 fps :(
2014-08-29 17:25:21
WIHT i5 , 60 FPS :O ?
2014-08-29 17:31:02
He is probably playing on 1920x1080 with everything maxed in that case you will get 60 fps which imo is pretty much unplayable. What you have to do is lower some of those settings for example I only keep global shadows on high everything else is on low (still looks good) in the same res which boost the fps to over 200. But yeah for some reason when maxed up the fps caps at 60fps.
2014-08-29 20:08:39
i5 4690K (no overclock)
MSI GAMING 3 H97
MSI GEFORCE GTX 650

nvidia control panel @ performance
220-250 fps

only my autoexec.cfg in start-up
fps_max 300
2014-08-29 17:33:44
me with overclock
350 fps.
i5 2500k oc'ed to 4ghz + nvidia control = performance
and gtx 570
2014-08-29 19:32:34
Ive got an i7 and I get 80 fps g_G
2014-08-29 20:09:59
+1 thanks dude! YOU DA REAL MVP

Post edited 2014-08-29 18:55:59
2014-08-29 18:55:46
Nothing changed for me.
http://www.hltv.org/?pageid=135&userid=185656&..
2014-08-29 19:30:42
setting.mat_queue_mode and -threads affects hit registry?
2014-08-29 19:37:33

Login or register to add your comment to the discussion.