Thread has been deleted
Last comment
Faceit turned portuguese
Sweden memorate 
Any ideas how to turn it back to english?
2016-12-30 16:29
Topics are hidden when running Sport mode.
I have no frigging idea what is going on
2016-12-30 16:29
#2
Europe daviq 
faceit turned cheater hood
2016-12-30 16:31
lmao
2016-12-30 16:35
But you are swedish?
2016-12-30 16:35
Yes, but for some reason faceit.com/pt shows up even when I load faceit.com/en or /se It doesnt make any sense like wtf
2016-12-30 16:38
change ur vpn
2016-12-30 16:39
#13
Jame | 
Iceland xijmplr 
gyazo.com/d5e5cbdd829bd1611a648d3cc96f25.. there is "languages" setting in left bottom
2016-12-30 16:46
#5
 | 
Denmark NikoHeiseN 
Hola senor
2016-12-30 16:36
#6
 | 
Portugal Stifmyster 
just change the adress to "en" insted of "pt" LOL
2016-12-30 16:38
I've done that yet it automatically resolves back to pt once the site loads
2016-12-30 16:40
#11
 | 
Portugal Stifmyster 
try to go to settings-conta-idioma and change to english
2016-12-30 16:41
#8
 | 
Brazil NaScene 
FaceIT in 2016 LUL
2016-12-30 16:39
madlikewizards
1.41
PC419
2.83
FaZe
1.45
NiP
2.69
Natus Vincere
1.93
Vitality
1.84
Bet value
Amount of money to be placed
Winning
Odds total ratio
-
Login or register to add your comment to the discussion.