Thread has been deleted
Last comment
CSGO bug ?
s1mple | 
CIS vodkacspro 
Im the only one that cant talk ingame anymore when i click my bind to talk it does nothing
2018-05-11 16:06
Topics are hidden when running Sport mode.
Go to Steam>Settings>Voice>choose your primary mic
2018-05-11 16:15
Login or register to add your comment to the discussion.